Tuesday, 25 March 2008

WebSphere Portal Express 6.1 Beta - So far, so good

Well, the installation went smoothly ( the second time 'cos the disk on
which the VMware image resides ran out of space ). Unlike previous
iterations of the beta, I've chosen to download and install the Linux
code, and am using Red Hat Enterprise Linux.

Points of Interest: -

* Logs have finally been tidied up in a consistent manner - in my
case, they are now in
/opt/WebSphere/AppServer/profiles/wp_profile/logs/WebSphere_Portal
* Older log directories still exist but appear to be mainly unused
e.g. /opt/WebSphere/PortalServer/log and
/opt/WebSphere/AppServer/logs remain but are empty
* Just when I got used to WebSphere Portal 6.0 listening on 10038,
they've gone and moved it to 10040 - hey, change is good, right ?
* The user interface is much sharper - more use of tabbed pages, and
lots of Ajax in the default pages
* The launch menu/button has been moved and is now called More.. -
the most commonly used pages e.g. Home, Administration, Web
Content have their own tabs
* JSPs appear to be precompiled by default, meaning that there is
less wait time on the initial page load - this used to be a pain
with earlier versions of WP; one had to remember to hit all the
pages in advance of a custmer demo :-)

Will post screenshots shortly ....

3 comments:

Olivier said...

Why do the hell they change the port on each release ?!

candobetter said...

Hi Dave! look forward to a demo.

Dave Hay said...

@Olivier - my $0.10 is that WebSphere Portal is finally being brought fully into line with WebSphere Application Server and its profiles - perhaps 10038 was already taken

@Candobetter - works for me :-)