Sunday, 22 November 2009

IBM HTTP Server installation wizard - not very wizardly

Whilst trying to install IBM HTTP Server 6.1 on Orac, I was getting very frustrated with my inability to get the installation running. Regardless of what I did, I wasn't able to get the normal installation wizard to run, either via a normal X11 GUI or via VNC. In all cases, the wizard "whinged" about the browser, even though I had the latest version of Firefox installed.

Realising that the installation wizard was actually trying to run a Java JAR file ( setup.jar ), I tried running it by hand using the command: -

java -jar setup.jar

from the IHS directory which is generated when one expands the installation package, supplied by: -

C87PSML.tar.gz  WebSphere Application Server V6.1 Supplements for Linux on x86Series, 32-bit Support

or

C87XSML .tar.gz WebSphere Application Server V6.1 Supplements for Linux on x86Series, 64-bit Support

but I then got the error: -

The wizard cannot continue because of the following error: could not load wizard specified in /wizard.inf (104)

which is particularly useful :-(

However, thinking laterally, I thought that the installer MIGHT be looking for the WAS JVM, so I ran: -

. /opt/IBM/WebSphere/AppServer/profiles/AppSrv01/bin/setupCmdLine.sh 
java -jar setup.jar

which did the trick :-)

3 comments:

Carl said...

Sounds like one of the better IBM installers :D

Dave Hay said...

@Carl - indeed :-)

Lotus Evangelist said...

Or in a windows box, make sure jvm is in the path, which lately, for whatever reason it has not in some servers I have been working on.
Excellent Work!