Monday, 29 February 2016

IBM BPM and Java6

IBM BPM 8.5.5, on which we're currently deployed, only supports Java6, via the underlying WebSphere Application Server.

I wanted to see what specific version of  Java we had ( with WAS ND 8.5.5.5 )

/opt/IBM/WebSphere/AppServer/java/bin/java -version

java version "1.6.0"
Java(TM) SE Runtime Environment (build pxa6460_26sr8fp3-20141218_02(SR8 FP3))
IBM J9 VM (build 2.6, JRE 1.6.0 Linux amd64-64 Compressed References 20141211_226933 (JIT enabled, AOT enabled)
J9VM - R26_Java626_SR8_20141211_2359_B226933
JIT  - r11.b07_20141003_74578.05
GC   - R26_Java626_SR8_20141211_2359_B226933_CMPRSS
J9CL - 20141212_226933)
JCL  - 20141216_01


/opt/IBM/WebSphere/AppServer/java/bin/java -fullversion

java full version "JRE 1.6.0 IBM Linux build pxa6460_26sr8fp3-20141218_02 (SR8 FP3)"

I then upgraded WAS to 8.5.5.8 ( aka Fixpack 8 ), and now see: -

/opt/IBM/WebSphere/AppServer/java/jre/bin/java -version

java version "1.6.0"
Java(TM) SE Runtime Environment (build pxa6460_26sr8fp7ifix-20150930_01(SR8 FP7+IV77422+IV77423+IX90164))
IBM J9 VM (build 2.6, JRE 1.6.0 Linux amd64-64 Compressed References 20150701_255671 (JIT enabled, AOT enabled)
J9VM - R26_Java626_SR8_20150701_0100_B255671
JIT  - tr.r11_20150626_95120.01
GC   - R26_Java626_SR8_20150701_0100_B255671_CMPRSS
J9CL - 20150701_255671)
JCL  - 20150628_01


/opt/IBM/WebSphere/AppServer/java/jre/bin/java -fullversion

java full version "JRE 1.6.0 IBM Linux build pxa6460_26sr8fp7ifx-20150930_01 (SR8 FP7)"

which is nice.

For the record, SR8 FP7 equates to 6.0.1 Service Refresh 8 Fix Pack 7, as per this list: -



No comments: