Thursday, 4 September 2008

Upgrading Lotus Quickr Services for Lotus Domino 8.1 to Hotfix 19

Well, I went through this three times before I got it working. Mainly it's because I'm a Londoner a muppet, but I was getting very confused.

In the end, I went with: -
  1. Install Lotus Domino 8.0.1
  2. Start the server to perform the initial configuration, allocate an administrative user ( domadmin ), load the HTTP task etc.
  3. Stop the server
  4. Install Lotus Quickr Services for Lotus Domino 8.1 ( I opted to use the same user ID - domadmin - and password for the Quickr installation, even though my first act would be to configure it to use Domino Directory )
  5. Start the server
  6. Open a browser to the default Quickr home page: -

    http://hostname.domain.com/LotusQuickr/lotusquickr/main.nsf

  7. Log in using the domadmin user ID and password
  8. Configure Quickr to use Domino Directory
  9. Log out
  10. Stop the server
  11. Copy 8.1-Quickr-Domino-HF19-ENGLISH.jar to C:\Lotus\Domino\jvm\lib\ext
  12. Add C:\Lotus\Domino to the Windows system path
  13. Execute the JAR file and point it at the notes.ini file in C:\Lotus\Domino
  14. Once installed, start the server
  15. Unlock and upgrade the Quickr databases: -

    load qptool unlock –a
    load qptool upgrade -f –server
    load qptool upgrade -f –a

  16. Job done
When I start the HTTP task, I can see that Hotfix 19 is applied: -









as well as in the page source: -

3 comments:

Chris said...

It's great to see other people's upgrade scripts like this. Thanks for sharing.

I noticed you used an admin account from the Domino directory for the Quickr administrater. If you read Rob Novak's post here http://www.lotusrockstar.com/blog/robblog.nsf/d6plinks/RNOK-7J58J4

...you will see that #10 recommends that you NOT used an admin account from the directory.

FWIW

Dave Hay said...

Hi Chris, thanks for your input - you're quite right; I would be following Rob's advice if this wasn't purely a desvelopment/test environment. Thanks for the feedback; much appreciated, regards, Dave

marneum said...

It seems like all fixes to Quickr 8.1 currently are available for English only. I was trying to apply HF19 to my German installation, it worked fine until I found out that all templates were english after install... Does anyone know if there is a solution?