Friday, 21 January 2011

Installing WebSphere Portal 7 on Ubuntu 10.10

Following on from a previous blog post, I tried, and FAILED, to install WebSphere Portal Express 7 on my Thinkpad W500, which runs Ubuntu 10.10.

The failure occurs during the creation of the WAS profile, known as wp_profile, and I saw errors such as: -

<message>Value of PRE_IJC_LIB could not be extracted from the process environment, returning null</message>
<message>Could not resolve this argument: PRE_IJC_LIB, returning null</message>
<message>Value of POST_IJC_LIB could not be extracted from the process environment, returning null</message>
<message>Could not resolve this argument: POST_IJC_LIB, returning null</message>
<message>ConfigManager action execution failed on a fatal action</message>
<message>Creation of profile wp_profile at path /opt/IBM/WebSphere/AppServer/profiles/wp_profile failed.</message>
<message>INSTCONFFAILED: The profile could not be created.  For more information, consult the /opt/IBM/WebSphere/AppServer/logs/manageprofiles/wp_profile_create.log file.</message>

etc.

At the time, I didn't have the time or energy to dig into the problem last night, but my brain was nagging me to look at the default shell being used.

In the past, I've been caught out repeatedly by the fact that, by default, Ubuntu uses the dash shell, which breaks the wsadmin script.

In order to check, I ran the following commands: -

echo $SHELL

which returns: -

/bin/bash

and: -

which sh

which returns: -

/bin/sh

and: -

ll/bin/sh

which returns: -

/bin/sh -> dash*

There are two ways to resolve this: -

(a) Hacky

cd /bin
unlink sh
ln -s /bin/bash sh

I'll test this and report back ...

*UPDATE* Yep, that did it - once I unlinked dash, all was well ....

2 comments:

Metastasis said...

yea this really work, websphere process server 7 on linux ubuntu x64 INSTCONFPARTIALSUCCESS
wsadmin task failed with return code :-1

mark said...

Second way to resolve this: sudo dpkg-reconfigure dash