Saturday, 25 February 2012

Installing Rational Software Architect 8.0.3 on CentOS Linux 6.2

More fun with CentOS, this time it's Rational Software Architect …

Initially, I saw the same sort of issues that I'd previously seen with IBM HTTP Server including: -

...
/bin/bash: /tmp/RSA803/RSA_SETUP/InstallerImage_linux_gtk_x86/install: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory


...
libgcc_s.so.1 must be installed for pthread_cancel to work

which I resolved with: -

$ sudo yum install ld-linux.so.2

and

$ sudo yum install libgcc_s.so.1

respectively.

However, I was still struggling, with errors such as: -

$ ./InstallerImage_linux_gtk_x86/installc -acceptLicense

CRIMA9C35370BE ERROR: The package IBM® Rational® Software Architect requires system library libstdc++.so.5 or libstdc++.so.6. Make sure libstdc++.so.5 or libstdc++.so.6 is available in the system library path before installing this package.

which I resolved with: -

$ yum install libstdc++.so.6

and: -

$ ./InstallerImage_linux_gtk_x86/installc -acceptLicense

java.io.IOException: Cannot run program "lsb_release": java.io.IOException: error=2, No such file or directory

which I resolved with: -

$ sudo yum install redhat-lsb

Finally, I needed to use strace as follows to dig into the additional missing packages e.g. 

$ strace -o /tmp/output.txt ./InstallerImage_linux_gtk_x86/installc -acceptLicense

which led me to install these additional packages: -

$ sudo yum install libX11.so.6
$ sudo yum install libgdk-x11-2.0.so.0
$ sudo yum install libpk-gtk-module.so
$ sudo yum install libcanberra-gtk-module.so

Having done that, the RSA 803 installation took 5-10 minutes.

Job done :-)

No comments: