Tuesday, 10 August 2010

VMware Ate My Keyboard

Just hit an interesting little problem ( aka bug or feature ) in VMware Workstation 7.1.0 build 261024 running under Ubuntu 10.0.4 on a Thinkpad W500.

For no apparent reason, the so-called special modifier keys ( Ctrl, Shift etc. ) stopped working in the host OS, even though they continued working within a running VM ( Red Hat Enterprise Linux 5.5, in case it helps ).

The symptoms included the inability to use [Shift] to achieve CAPITALS or get special characters such as currency ( £, $ ), punctuation symbols ( !, ? ) etc.

This made life somewhat difficult for me.

As always, Google had the answer, Google is my friend, with this old post from 2008: -
Workstation 6 + Xorg 7.3 - keyboard issues
http://ubuntuforums.org/showthread.php?p=4990785#post4990785

which directs one to run the command /usr/bin/setxkbmap - no parameters etc. needed.

That was all I needed to do - the special modifier keys burst back into life, and I didn't have to "turn it off and on again"

Roy: [answers phone] Hello, IT. Have you tried turning it off and on again? ... OK, well, the button on the side. Is it glowing? ... Yeah, you need to turn it on. Err, the button turns it on. Yeah, you do know how a button works, don't you? No, not on clothes.
[Moss's phone rings. He answers it.]
Moss: Hello IT. Yuhuh. Have you tried forcing an unexpected reboot?
Roy: No, there you go, I just heard it come on. No, that's the music you hear when it comes on. No, that's the music you hear when... I'm sorry, are you from the past?
Moss: You see the driver hooks a function by patching the system call table so it's not safe to unload it unless another thread is going to jump in there and do its stuff and you don't want to end up in the middle of invalid memory... Hello?


http://en.wikiquote.org/wiki/The_IT_Crowd

No comments:

Grokking grep

A colleague was tinkering with grep  and, thanks to him, I discovered a bit more about the trusty little utility. I had not really explored ...