Tuesday, 14 December 2010

Lotus Connections 3.0 - Error message CLFRP0016E: The WebSphere Application Server version is not supported

It may be kinda obvious, but seeing this error: -

CLFRP0016E: The WebSphere Application Server version is not supported

during my first ever Lotus Connections 3.0 installation spooked me.

Until I read the error message more clearly ....

I'd previously assumed that I had the right version of WAS installed - WebSphere Application Server Network Deployment 7.0.0.9.

Doh ! When I checked the System Requirements (Linux) document here, I realised that I actually need WebSphere Application Server Network Deployment 7.0.0.11.

Do I feel daft, or what ?

Unlike previous versions of LC, it looks like LC30 is a lot more focused on ensuring that the system requirements are right first time.

After my previous fun and games with the Profiles wizard and TDI 7, I'm determined to get it right ....

6 comments:

Raj said...

Dave,

is it possible to upgrade from WAS ND 7.0 to 7.0.0.11 ?

I have already installed ND 7.0 and don't want to uninstall / reinstall again.

Please let me know if there is an option.

Thanks,
Raj

Dave Hay said...

Hi Raj, yes, it's absolutely possible to upgrade from WAS ND 7.0.0.0 to 7.0.0.11. That's precisely what you have to do in order to install Connections.

You'll need the fixpack here: -

http://www-01.ibm.com/support/docview.wss?rs=180&uid=swg24026855

( choose the OS version you need )

and the Update Installer from here: -

http://www-01.ibm.com/support/docview.wss?rs=180&uid=swg24020446

( again choose your OS version )

Regards, Dave

Lester Nubla said...

Hi! Same thing happened for me. However, I have this colleague of mine who installed WAS 7.0 for Connections 3.0.1. It worked for her! I really don't understand what happened there because I got the error "The WebSphere Application Server version is not supported" and she did not. The only thing that is different in our installation is our LDAP. She used Domino while I used Active Directory.

I haven't tried the UpdateInstaller though. But I'm REALLY confused here.

Any comments?

Regards,

Lester

Dave Hay said...

Hi Lester, thanks for the comments. What version of WAS do you have ? Run versionInfo.sh / .bat. It needs to be 7.0.0.11 or higher - Connections 3.0.1.1 is now supported with WAS 7.0.0.21 ( as per the System Requirements page here http://www-01.ibm.com/support/docview.wss?uid=swg27021342#AIX_Application_Servers_sw )

Lester Nubla said...

Dear Dave,

Thanks for the info! Yes, I figured out that my WAS version is 7.0.0.0. However, I tried to install Connections 3.0 only, aside from what I installed first which is 3.0.1. I got the same error. Well, I think I have to download certain UpdateInstallers to fix this problem. I just hope that there would be no further problems. Thanks so much Dave!

Regards,

Lester

Dave Hay said...

Lester

Yes, you will definitely need to upgrade WAS to a minimum of 7.0.1.1. I've blogged about Update Installer here -> http://portal2portal.blogspot.co.uk/2012/06/following-script-installing-and-using.html