Friday, 31 August 2012

More on WebSphere Portal 8 and silent installs

Following on from my earlier posts: -

WebSphere Portal v8 on Red Hat Enterprise Linux - some lessons learned

WebSphere Portal v8 on Red Hat Enterprise Linux - revisited

I've been struggling with the precise incantation of a response-file to get WP8 to fully install, and kept hitting the same old error: -

<result>
<error uid="CRIMA1154E">
  Error installing.
</error>
<error>
  The silent installation process does not support installing packages that are contained on multiple media discs.</error>
</result>


Well, I think I've cracked it - at least, I found a response file that actually worked - I've yet to re-try a new installation using the same file, but will try that in the near future.

Here's the response file: -

<?xml version="1.0" encoding="UTF-8"?>
<!--The "acceptLicense" attribute has been deprecated. Use "-acceptLicense" command line option to accept license agreements.-->
<agent-input acceptLicense='true'>
<server>
<repository location='/mnt/hgfs/Lenovo/WP8/WAS'/>
<repository location='/mnt/hgfs/Lenovo/WP8/Setup/eimage/'/>
<repository location='/mnt/hgfs/Lenovo/WP8/Portal'/>
<repository location='/mnt/hgfs/Lenovo/WP8/Enable'/>
</server>
<profile id='IBM WebSphere Application Server Network Deployment V8.0' installLocation='/opt/IBM/WebSphere/AppServer'>
<data key='eclipseLocation' value='/opt/IBM/WebSphere/AppServer'/>
<data key='user.import.profile' value='false'/>
<data key='cic.selector.os' value='linux'/>
<data key='cic.selector.ws' value='gtk'/>
<data key='cic.selector.arch' value='x86'/>
<data key='cic.selector.nl' value='en'/>
</profile>
<install modify='false'>
<offering id='8.0.0.3-WS-WAS-TFPM59935' version='8.0.3.20120309_1201' profile='IBM WebSphere Application Server Network Deployment V8.0' features='-'/>
<offering id='8.0.0.3-WS-WAS-TFPM60670' version='8.0.3.20120319_1949' profile='IBM WebSphere Application Server Network Deployment V8.0' features='-'/>
<offering id='8.0.0.3-WS-WAS-TFPM61934' version='8.0.3.20120409_1230' profile='IBM WebSphere Application Server Network Deployment V8.0' features='-'/>
<offering id='8.0.0.3-WS-WASProd-TFPM60134' version='8.0.3.20120312_1656' profile='IBM WebSphere Application Server Network Deployment V8.0' features='-'/>
<offering id='com.ibm.websphere.ND.v80' version='8.0.3.20120320_0536' profile='IBM WebSphere Application Server Network Deployment V8.0' features='core.feature,ejbdeploy,thinclient,embeddablecontainer,com.ibm.sdk.6_64bit' installFixes='none'/>
<offering id='com.ibm.websphere.PORTAL.SERVER.v80' version='8.0.0.20120421_0828' profile='IBM WebSphere Portal Server V8' features='ce.install,portal.binary,portal.profile' installFixes='none'/>
<offering id='com.ibm.websphere.PORTAL.ENABLE.v80' version='8.0.0.20120421_0909' profile='IBM WebSphere Portal Server V8' features='enable.upsell' installFixes='none'/>
</install>
<profile id='IBM WebSphere Portal Server V8' installLocation='/opt/IBM/WebSphere/PortalServer'>
<data key='eclipseLocation' value='/opt/IBM/WebSphere/PortalServer'/>
<data key='user.import.profile' value='false'/>
<data key='cic.selector.os' value='linux'/>
<data key='cic.selector.ws' value='gtk'/>
<data key='cic.selector.arch' value='x86'/>
<data key='user.was.installLocation,com.ibm.websphere.PORTAL.SERVER.v80' value='/opt/IBM/WebSphere/AppServer'/>
<data key='user.profile.config.mode,com.ibm.websphere.PORTAL.SERVER.v80' value='standard'/>
<data key='user.wp.install.type,com.ibm.websphere.PORTAL.SERVER.v80' value='full'/>
<data key='user.iim.currentlocale,com.ibm.websphere.PORTAL.SERVER.v80' value='en'/>
<data key='user.wp.hostname,com.ibm.websphere.PORTAL.SERVER.v80' value='wp8d.uk.ibm.com'/>
<data key='user.wp.cellname,com.ibm.websphere.PORTAL.SERVER.v80' value='wp8dCell'/>
<data key='user.wp.nodename,com.ibm.websphere.PORTAL.SERVER.v80' value='wp8dNode'/>
<data key='user.wp.userid,com.ibm.websphere.PORTAL.SERVER.v80' value='wpsadmin'/>
<data key='user.wp.password,com.ibm.websphere.PORTAL.SERVER.v80' value='rbN1IaMAWYYtQxLf6KdNyA=='/>
<data key='user.wp.admin.port,com.ibm.websphere.PORTAL.SERVER.v80' value='10000'/>
<data key='user.wp.portal.port,com.ibm.websphere.PORTAL.SERVER.v80' value='10025'/>
<data key='user.was.forward.installLocation,com.ibm.websphere.PORTAL.SERVER.v80' value='/opt/IBM/WebSphere/AppServer'/>
<data key='user.wp.profilename,com.ibm.websphere.PORTAL.SERVER.v80' value='wp_profile'/>
<data key='user.common.installPath,com.ibm.websphere.PORTAL.SERVER.v80' value='/opt/IBM/WebSphere'/>
<data key='user.configengine.profileLocation,com.ibm.websphere.PORTAL.SERVER.v80' value='/opt/IBM/WebSphere/wp_profile/ConfigEngine'/>
<data key='user.configengine.binaryLocation,com.ibm.websphere.PORTAL.SERVER.v80' value='/opt/IBM/WebSphere/ConfigEngine'/>
<data key='user.configengine.forward.binaryLocation,com.ibm.websphere.PORTAL.SERVER.v80' value='/opt/IBM/WebSphere/ConfigEngine'/>
<data key='user.wp.profilepath,com.ibm.websphere.PORTAL.SERVER.v80' value='/opt/IBM/WebSphere/wp_profile'/>
<data key='user.wp.forward.profilepath,com.ibm.websphere.PORTAL.SERVER.v80' value='/opt/IBM/WebSphere/wp_profile'/>
<data key='user.was.uninstall.selected,com.ibm.websphere.PORTAL.SERVER.v80' value='false'/>
<data key='user.wp.uri.values.changed,com.ibm.websphere.PORTAL.SERVER.v80' value='false'/>
<data key='cic.selector.nl' value='en'/>
</profile>
<preference name='com.ibm.cic.common.core.preferences.eclipseCache' value='/opt/IBM/IMShared'/>
<preference name='com.ibm.cic.common.core.preferences.connectTimeout' value='30'/>
<preference name='com.ibm.cic.common.core.preferences.readTimeout' value='45'/>
<preference name='com.ibm.cic.common.core.preferences.downloadAutoRetryCount' value='0'/>
<preference name='offering.service.repositories.areUsed' value='true'/>
<preference name='com.ibm.cic.common.core.preferences.ssl.nonsecureMode' value='false'/>
<preference name='com.ibm.cic.common.core.preferences.http.disablePreemptiveAuthentication' value='false'/>
<preference name='http.ntlm.auth.kind' value='NTLM'/>
<preference name='http.ntlm.auth.enableIntegrated.win32' value='true'/>
<preference name='com.ibm.cic.common.core.preferences.preserveDownloadedArtifacts' value='true'/>
<preference name='com.ibm.cic.common.core.preferences.keepFetchedFiles' value='false'/>
<preference name='PassportAdvantageIsEnabled' value='false'/>
<preference name='com.ibm.cic.common.core.preferences.searchForUpdates' value='false'/>
<preference name='com.ibm.cic.agent.ui.displayInternalVersion' value='false'/>
<preference name='com.ibm.cic.common.sharedUI.showErrorLog' value='true'/>
<preference name='com.ibm.cic.common.sharedUI.showWarningLog' value='true'/>
<preference name='com.ibm.cic.common.sharedUI.showNoteLog' value='true'/>
</agent-input>


Note that I have highlighted the four lines that relate to the WAS / fixes / WP repositories that I'm using.

I've also highlighted the password that I used - bear in mind that this is a throw-away demo installation, so my password WAS actually passw0rd.

If it helps, you can see how Installation Manager "encrypts" passwords, using the following utility: -

$ /opt/IBM/InstallationManager/eclipse/tools/imutilsc encryptstring passw0rd

rbN1IaMAWYYtQxLf6KdNyA==

Obviously, in a production environment, we'll be using MUCH more secure passwords AND also federating in a LDAP repository PDQ after installation.

Here's the command that I used to run the installation: -

$ /opt/IBM/InstallationManager/eclipse/IBMIM -input ~/install_WP8_NEW.rsp -log ~/install_WP8_NEW.log -silent -acceptLicense

and here's the final output: -

Installed 8.0.0.3-WS-WAS-TFPM59935_8.0.3.20120309_1201 to the /opt/IBM/WebSphere/AppServer directory.
Installed 8.0.0.3-WS-WAS-TFPM60670_8.0.3.20120319_1949 to the /opt/IBM/WebSphere/AppServer directory.
Installed 8.0.0.3-WS-WAS-TFPM61934_8.0.3.20120409_1230 to the /opt/IBM/WebSphere/AppServer directory.
Installed 8.0.0.3-WS-WASProd-TFPM60134_8.0.3.20120312_1656 to the /opt/IBM/WebSphere/AppServer directory.
Installed com.ibm.websphere.ND.v80_8.0.3.20120320_0536 to the /opt/IBM/WebSphere/AppServer directory.
Installed com.ibm.websphere.PORTAL.SERVER.v80_8.0.0.20120421_0828 to the /opt/IBM/WebSphere/PortalServer directory.
Installed com.ibm.websphere.PORTAL.ENABLE.v80_8.0.0.20120421_0909 to the /opt/IBM/WebSphere/PortalServer directory.


I'm continuing to enjoy my voyage of discovery that is WebSphere Portal 8, and will have more posts to follow in the near future ....

#LifeIsGood

3 comments:

Michael Prendergast said...

somewhat belatedly was reviositing portal v8 install and noticed that hunter's im script creation script includes suppoert for non default context root on install...
So I tried it out
it adds these values





note the new context root of Connect instead of wps and that the final stanza
key='user.wp.uri.values.changed,com.ibm.websphere.PORTAL.SERVER.v80' value='true'
I'll have to actual make time to run this, and test it out.. but like you say if it's not written down

Michael Prendergast said...

woopps it didn't publish the values
data key='user.wp.custom.personalhome,com.ibm.websphere.PORTAL.SERVER.v80' value='myportal'
data key='user.wp.custom.defaulthome,com.ibm.websphere.PORTAL.SERVER.v80' value='portal'
data key='user.wp.custom.contextroot,com.ibm.websphere.PORTAL.SERVER.v80' value='Connect'
key='user.wp.uri.values.changed,com.ibm.websphere.PORTAL.SERVER.v80' value='true'

Dave Hay said...

@Michael - cool, thanks for the update