Tuesday, 20 July 2010

IBM Content Templates Catalog and the Admin. installation

Following my previous posts, including this one,  I'm rather keen on the IBM Content Templates Catalog (CTC) , but was getting an exception: -

[xmlaccess]     <status element="[web-app 1_CGAH47L000T950I4B4R9CD00U0 uid=FeedReaderPortlet.webmod]" result="failed">
[xmlaccess]         <message id="EJPXA0025E">com.ibm.wps.command.xml.XmlCommandException: EJPXA0025E: The resource was not found in the portal, either because it does not exist or because you have not specified an identifying attribute in the XML input. [web-app 1_CGAH47L000T950I4B4R9CD00U0 uid=FeedReaderPortlet.webmod]</message>
[xmlaccess]     </status>
[xmlaccess] </request>

[xmlaccess] EJPXB0015E: Server response indicates an error.
[xmlaccess] EJPXB0015E: Server response indicates an error.
Target finished: create-wcm-template-pages

when trying to install it into a newly minted installation of WebSphere Portal / Lotus Web Content Management 6.1.0.4.

Again, I'd performed a slimmed-down administration installation, which proved to be the problem.

The CTC installer was looking for the IBM Feed Reader Portlet, which wasn't installed.

I installed wp.bp.feedreader.war from /opt/IBM/WebSphere/PortalServer/installableApps/ and was able to successfully install the CTC.

I'm now seeing: -

[xmlaccess]     <status element="[portletinstance 5_LH0ANTS30O0V70I4JD9BIR3KF6]" result="warning">
[xmlaccess]         <message id="EJPXA0202W">com.ibm.wps.command.xml.XmlCommandException: EJPXA0202W: The user with the userid uid=wp1admin,o=defaultWIMFileBasedRealm could not be found. The resource [portletinstance 5_LH0ANTS30O0V70I4JD9BIR3KF6] will be not created. [portletinstance 5_LH0ANTS30O0V70I4JD9BIR3KF6]</message>
[xmlaccess]     </status>

but that may be a herring rouge ...

No comments:

More fun with pip

Again with the Python and pip  fun, this time on my Mac, where commands such as:  pip3 list and: - pip3 install --upgrade pip were failing w...