Tuesday, 20 July 2010

"The specified product version is not supported: version=6.1.0.27" seen whilst attempting to upgrade to WebSphere Portal 6.1.0.4

I was seeing these exceptions: -

Failed to perform extraction.

Exception: WUPD0248E: Fix pack update failure: The processing of fix pack WP_PTF_6104, component wp.ptf.preconfig failed.  See the log file /opt/IBM/WebSphere/PortalServer/version/log/20100719_160024_WP_PTF_6104_wp.ptf.preconfig_install.log for processing details.

and

2010-07-19T16:06:44+01:00 Result: StdErr:
2010-07-19T16:06:44+01:00 Result: Adding ENTITY for wp.oob.full_cfg
2010-07-19T16:06:44+01:00 Result: StdErr: BUILD FAILED
2010-07-19T16:06:44+01:00 Result: Adding ENTITY for wp.oob.full.fp_cfg
2010-07-19T16:06:44+01:00 Result: StdErr: /opt/IBM/WebSphere/PortalServer/installer/wp.config/config/includes/preconfig_wp_ptf_6104.xml:24: The following error occurred while executing this line:
2010-07-19T16:06:44+01:00 Result: Adding ENTITY for wp.ap.managewebservices.fp_cfg
2010-07-19T16:06:44+01:00 Result: StdErr: /opt/IBM/WebSphere/PortalServer/installer/wp.config/config/includes/preconfig_wp_ptf_6104.xml:384: The following error occurred while executing this line:
2010-07-19T16:06:44+01:00 Result: Adding ENTITY for wp.ai.io.impl.catalog_cfg
2010-07-19T16:06:44+01:00 Result: StdErr: /opt/IBM/WebSphere/PortalServer/installer/wp.config/config/includes/upgrade_health_check.xml:29: The following error occurred while executing this line:
2010-07-19T16:06:44+01:00 Result: Adding ENTITY for wp.bp.exchange2003.fp_cfg
2010-07-19T16:06:44+01:00 Result: StdErr: /opt/IBM/WebSphere/PortalServer/installer/wp.config/config/includes/upgrade_health_check.xml:118: The specified product version is not supported: version=6.1.0.27
2010-07-19T16:06:44+01:00 Result: Adding ENTITY for dpi-st-portal
2010-07-19T16:06:44+01:00 Result: StdErr:
2010-07-19T16:06:44+01:00 Result: Adding ENTITY for dpi-server-list
2010-07-19T16:06:44+01:00 Result: StdErr: Total time: 11 seconds

whilst trying to install the latest 6.1.0.4 fixpack onto an installation of WebSphere Portal Server / Lotus Web Content Management 6.1.0.3. I'd previously seen the same exception last week, on another VM, but hadn't had a chance to dig into it further.

Sadly, I'd seen the messages but hadn't really read the messages :-)

When I read into it more fully, the significance of "the specified product version is not supported: version=6.1.0.27" became more relevant; WebSphere Portal 6.1.0.3 ships with, and installs by default, WebSphere Application Server 6.1.0.27, whereas 6.1.0.4 requires WebSphere Application Server 6.1.0.29, as per: -

WebSphere Portal Express V6.1.0.4 and V6.1.5.1 hardware and software requirements - Linux on x86

http://www-01.ibm.com/support/docview.wss?uid=swg27018305

Once I installed the .29 fixpacks: -

6.1.0-WS-WAS-LinuxX32-FP0000029.pak
6.1.0-WS-WASSDK-LinuxX32-FP0000029.pak

I was able to successfully install the 6.1.0.4 fixpack.

Can you say "Muppet" ? I bet you can ......

No comments:

More fun with pip

Again with the Python and pip  fun, this time on my Mac, where commands such as:  pip3 list and: - pip3 install --upgrade pip were failing w...